AWS Outage/Issues

Incident Report for RebelGive

Resolved

All systems are operational again.
Posted Jun 13, 2023 - 18:50 EDT

Update

AWS has resolved the incident. Some event processing may be delayed as the system catches back up.
Posted Jun 13, 2023 - 17:50 EDT

Update

From AWS: Many AWS services are now fully recovered and marked Resolved on this event. We are continuing to work to fully recover all services.
Posted Jun 13, 2023 - 17:03 EDT

Update

In case you want to follow along with Amazon's side of this:
https://health.aws.amazon.com/health/status
Posted Jun 13, 2023 - 15:28 EDT

Monitoring

Some AWS services seem to be struggling and may cause intermittent loading issues on Nucleus 2 Products + the Nucleus 2 Admin dashboard. This could affect any of the RebelGive or N2 products, and we are monitoring for a fix/update from AWS regarding this outage/intermittent issues that seem to be building steam currently.
Posted Jun 13, 2023 - 15:06 EDT
This incident affected: API, GivingFlows, Control Center, Credit Card Payment Processing, and ACH Payment Processing.