Thank you for your patience as we continue to address the ongoing issues with our payment processor.
Latest Update:
Reversal of Duplicate Charges: Our payment processor is continuing to reverse duplicate charges. This process is ongoing, and we will keep you informed as we receive updates.
Updated ACH Transactions: We have updated the status of failed ACH transactions in our system to match the latest information from BluePay. As a result, many gifts that were previously marked as failed are now marked as successful or paid out.
Potential Refunds: Some givers may have made a second gift due to the initial transaction failure. For those original gifts that have now been paid out, refunds can be processed by the church as needed.
Investigating Transfer Data: We are investigating any impact this may have on Transfer data and are working to ensure that Transfers accurately depict which transactions have been paid out.
You can find the latest status updates from our payment processor at the link below:
We appreciate your understanding and patience as we work through these issues. If you have any questions or concerns, please feel free to contact our support team.
Posted Jun 26, 2024 - 19:13 EDT
Update
Thank you for your patience as we continue to monitor the situation and await updates from our payment processor.
Key Updates:
Reversals of Double Settled Transactions: The payment processor has begun reversing duplicate transactions, starting with large transactions over $10,000. These reversals are pending settlement and are expected to be completed by the end of the day on Monday, June 24, 2024. Smaller transactions under $10,000 are also being reversed and should be completed by the same date.
ACH and Credit Card Transactions: Both ACH and credit card transactions may have been double settled. The reversal of all double-settled transactions is in progress.
Restoration of Missing Data: The payment processor has completed the restoration of the missing data that resulted in ACH transactions being marked as failed. We will soon begin updating our records to reflect the correct status from our payment processor.
We are closely monitoring the situation and will update you once the payment processor has fully resolved the issue and ACH gifts are being processed successfully. You can find status updates from our card processor at the link below:
Thank you for your continued understanding and patience as we work through this matter.
Posted Jun 24, 2024 - 13:18 EDT
Monitoring
Update - Recurring Gifts Resumed
We are pleased to inform you that we have resumed all recurring giving, including ACH and credit card gifts. Any gifts that were scheduled during the time that recurring giving was paused will be caught up and processed today.
Key Information:
Resumed Recurring Giving processing: All missed recurring gifts will be processed tonight. You do not need to take any additional action.
Duplicate Transactions: We are still waiting to hear from our payment processor about when duplicate transactions will be reversed. We understand the urgency of this issue and will provide updates as soon as we have more information.
Monitoring: We are closely monitoring the situation to ensure that all transactions are processed smoothly and accurately.
Thank you for your patience and understanding as we resolved the issues with our payment processor. If you have any questions or concerns, please feel free to contact our support team.
Posted Jun 22, 2024 - 01:42 EDT
Update
We are continuing to experience issues with our payment processor affecting ACH gifts since June 18, 2024, at 4:16 PM EDT.
Key Issues:
Double Charges: Some transactions have been double charged due to a data synchronization problem. Our payment processor is actively working to identify and reverse these duplicate charges.
Failed Transactions: One-time and recurring ACH gifts made during the affected period are failing and will not be retried automatically. Affected givers have received a failed transaction email.
Impact on Givers:
Recurring Gifts Turned Off: All recurring giving, including ACH and credit card gifts, has been turned off temporarily. Recurring gift schedules will not attempt to process until the issue is resolved.
Duplicate Withdrawals: Some givers are reporting that they have had duplicate gifts withdrawn from their bank accounts. We are waiting to hear from our payment processor on how they plan to reverse those duplicate charges.
Next Steps:
We are closely monitoring the situation and will update you once the payment processor has fully resolved the issue and ACH gifts are being processed successfully. You can find status updates from our card processor at the link below.
Thank you for your continued understanding and patience as we work through this matter.
Posted Jun 21, 2024 - 10:45 EDT
Investigating
We are currently experiencing an issue with our payment processor that has resulted in failed ACH gifts starting on June 18, 2024, at 4:16 PM EDT. Both one-time and recurring ACH gifts made during this period are failing and will not be retried. Affected givers will receive a failed transaction email.
Please note that recurring gift schedules with failed ACH gifts have not been turned off. These schedules will attempt the next regularly scheduled gift as intended. Givers who wish to retry the failed recurring gift can make a one-time gift after the outage has been resolved.
We will provide an update once the outage is resolved and ACH gifts are being processed successfully. Thank you for your understanding and patience.