Increased error rates

Incident Report for RebelGive

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 18:09 EDT

Monitoring

Amazon Web Services has identified and fixed the root cause of the outage. We observe error rates beginning to drop in Nucleus as services recover.
Posted Oct 20, 2025 - 16:08 EDT

Investigating

We are observing increased error rates across our services caused by an ongoing service degradation with our service provider: Amazon Web Services.
Posted Oct 20, 2025 - 11:42 EDT
This incident affected: API, GivingFlows, Control Center, Credit Card Payment Processing, and ACH Payment Processing.